USN-10-1: XML library vulnerabilities

30 October 2004

XML library vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 4.10

Software Description

Details

Several buffer overflows have been discovered in libxml2’s FTP connection and DNS resolution functions. Supplying very long FTP URLs or IP addresses might result in execution of arbitrary code with the privileges of the process using libxml2.

Since libxml2 is used in packages like php4-imagick, the vulnerability also might lead to privilege escalation, like executing attacker supplied code with a web server’s privileges.

However, this does not affect the core XML parsing code, which is what the majority of programs use this library for.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 4.10
libxml2

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

References