USN-1002-1: PostgreSQL vulnerability

7 October 2010

postgresql-8.1, postgresql-8.3, postgresql-8.4 vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 10.04 LTS
  • Ubuntu 9.10
  • Ubuntu 9.04
  • Ubuntu 8.04 LTS
  • Ubuntu 6.06 LTS

Summary

Software Description

  • postgresql-8.4
  • postgresql-8.3
  • postgresql-8.1

Details

It was discovered that PostgreSQL did not properly enforce permissions within sessions when PL/Perl and PL/Tcl functions or operators were redefined. A remote authenticated attacker could exploit this to execute arbitrary code with permissions of a different user, possibly leading to privilege escalation.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 10.04 LTS
postgresql-plperl-8.4 - 8.4.5-0ubuntu10.04
postgresql-pltcl-8.4 - 8.4.5-0ubuntu10.04
Ubuntu 9.10
postgresql-plperl-8.4 - 8.4.5-0ubuntu9.10
postgresql-pltcl-8.4 - 8.4.5-0ubuntu9.10
Ubuntu 9.04
postgresql-plperl-8.3 - 8.3.12-0ubuntu9.04
postgresql-pltcl-8.3 - 8.3.12-0ubuntu9.04
Ubuntu 8.04 LTS
postgresql-plperl-8.3 - 8.3.12-0ubuntu8.04
postgresql-pltcl-8.3 - 8.3.12-0ubuntu8.04
Ubuntu 6.06 LTS
postgresql-plperl-8.1 - 8.1.22-0ubuntu0.6.06
postgresql-pltcl-8.1 - 8.1.22-0ubuntu0.6.06

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

This update uses a new upstream release, which includes additional bug fixes. In general, a standard system update will make all the necessary changes.

References