USN-1009-1: GNU C Library vulnerabilities

22 October 2010

glibc, eglibc vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 10.10
  • Ubuntu 10.04 LTS
  • Ubuntu 9.10
  • Ubuntu 9.04
  • Ubuntu 8.04 LTS

Summary

Local root escalation via LD_AUDIT environment variable.

Software Description

  • eglibc - GNU C Library
  • glibc - GNU C Library

Details

Tavis Ormandy discovered multiple flaws in the GNU C Library’s handling of the LD_AUDIT environment variable when running a privileged binary. A local attacker could exploit this to gain root privileges. (CVE-2010-3847, CVE-2010-3856)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 10.10
libc6 - 2.12.1-0ubuntu8
Ubuntu 10.04 LTS
libc6 - 2.11.1-0ubuntu7.5
Ubuntu 9.10
libc6 - 2.10.1-0ubuntu18
Ubuntu 9.04
libc6 - 2.9-4ubuntu6.3
Ubuntu 8.04 LTS
libc6 - 2.7-10ubuntu7

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References