USN-1012-1: CUPS vulnerability

4 November 2010

cups, cupsys vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 10.10
  • Ubuntu 10.04 LTS
  • Ubuntu 9.10
  • Ubuntu 8.04 LTS
  • Ubuntu 6.06 LTS

Summary

Software Description

  • cups
  • cupsys

Details

Emmanuel Bouillon discovered that CUPS did not properly handle certain Internet Printing Protocol (IPP) packets. A remote attacker could use this flaw to cause a denial of service or possibly execute arbitrary code. In the default installation in Ubuntu 8.04 LTS and later, attackers would be isolated by the CUPS AppArmor profile.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 10.10
cups - 1.4.4-6ubuntu2.2
Ubuntu 10.04 LTS
cups - 1.4.3-1ubuntu1.3
Ubuntu 9.10
cups - 1.4.1-5ubuntu2.7
Ubuntu 8.04 LTS
cupsys - 1.3.7-1ubuntu3.12
Ubuntu 6.06 LTS
cupsys - 1.2.2-0ubuntu0.6.06.20

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References