USN-1024-2: OpenJDK regression

13 December 2010

openjdk-6 regression

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 10.10

Summary

Fix bug during certain Java compilations.

Software Description

  • openjdk-6 - Alternative JVM for OpenJDK, using Cacao

Details

USN-1024-1 fixed vulnerabilities in OpenJDK. Some of the additional backported improvements could interfere with the compilation of certain Java software. This update fixes the problem.

We apologize for the inconvenience.

Original advisory details:

It was discovered that certain system property information was being leaked, which could allow an attacker to obtain sensitive information.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 10.10
openjdk-6-jdk - 6b20-1.9.2-0ubuntu2

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system update you need to restart any Java services, applications or applets to make all the necessary changes.

References