USN-1027-1: Quagga vulnerabilities

7 December 2010

quagga vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 10.04 LTS
  • Ubuntu 9.10
  • Ubuntu 8.04 LTS
  • Ubuntu 6.06 LTS

Summary

Software Description

  • quagga

Details

It was discovered that Quagga incorrectly handled certain Outbound Route Filtering (ORF) records. A remote authenticated attacker could use this flaw to cause a denial of service or potentially execute arbitrary code. The default compiler options for Ubuntu 8.04 LTS and later should reduce the vulnerability to a denial of service. (CVE-2010-2948)

It was discovered that Quagga incorrectly parsed certain AS paths. A remote attacker could use this flaw to cause Quagga to crash, resulting in a denial of service. (CVE-2010-2949)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 10.04 LTS
quagga - 0.99.15-1ubuntu0.1
Ubuntu 9.10
quagga - 0.99.13-1ubuntu0.1
Ubuntu 8.04 LTS
quagga - 0.99.9-2ubuntu1.4
Ubuntu 6.06 LTS
quagga - 0.99.2-1ubuntu3.7

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References