USN-1032-1: Exim vulnerability

11 December 2010

exim4 vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 9.10
  • Ubuntu 8.04 LTS
  • Ubuntu 6.06 LTS

Summary

A remote attacker could send crafted email to gain root access.

Software Description

  • exim4 - exim MTA

Details

Sergey Kononenko and Eugene Bujak discovered that Exim did not correctly truncate string expansions. A remote attacker could send specially crafted email traffic to run arbitrary code as the Exim user, which could also lead to root privileges.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 9.10
exim4-daemon-custom - 4.69-11ubuntu4.1
exim4-daemon-heavy - 4.69-11ubuntu4.1
exim4-daemon-light - 4.69-11ubuntu4.1
Ubuntu 8.04 LTS
exim4-daemon-custom - 4.69-2ubuntu0.2
exim4-daemon-heavy - 4.69-2ubuntu0.2
exim4-daemon-light - 4.69-2ubuntu0.2
Ubuntu 6.06 LTS
exim4-daemon-custom - 4.60-3ubuntu3.2
exim4-daemon-heavy - 4.60-3ubuntu3.2
exim4-daemon-light - 4.60-3ubuntu3.2

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References