USN-1039-1: AppArmor update

7 January 2011

apparmor update

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 10.10
  • Ubuntu 10.04 LTS
  • Ubuntu 9.10

Summary

AppArmor did not properly handle execute permissions under certain circumstances.

Software Description

  • apparmor - User-space parser utility for AppArmor

Details

It was discovered that if AppArmor was misconfigured, under certain circumstances the parser could generate policy using an unconfined fallback execute transition when one was not specified.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 10.10
apparmor - 2.5.1-0ubuntu0.10.10.3
Ubuntu 10.04 LTS
apparmor - 2.5.1-0ubuntu0.10.04.2
Ubuntu 9.10
apparmor - 2.3.1+1403-0ubuntu27.4

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References