USN-1040-1: Django vulnerabilities

7 January 2011

python-django vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 10.10
  • Ubuntu 10.04 LTS
  • Ubuntu 9.10

Summary

An attacker could send crafted input to Django and cause it to utilize too many resources.

Software Description

  • python-django - High-level Python web development framework

Details

Adam Baldwin discovered that Django did not properly validate query string lookups. This could be exploited to provide an information leak to an attacker with admin privilieges. (CVE-2010-4534)

Paul McMillan discovered that Django did not validate the length of the token used when generating a password reset. An attacker could exploit this to cause a denial of service via resource exhaustion. (CVE-2010-4535)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 10.10
python-django - 1.2.3-1ubuntu0.2.10.10.1
Ubuntu 10.04 LTS
python-django - 1.1.1-2ubuntu1.2
Ubuntu 9.10
python-django - 1.1.1-1ubuntu1.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References