USN-1047-1: AWStats vulnerability

24 January 2011

awstats vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 10.10
  • Ubuntu 10.04 LTS
  • Ubuntu 9.10
  • Ubuntu 8.04 LTS
  • Ubuntu 6.06 LTS

Summary

Software Description

  • awstats

Details

It was discovered that AWStats did not correctly filter the LoadPlugin configuration option. A local attacker on a shared system could use this to inject arbitrary code into AWStats.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 10.10
awstats - 6.9.5~dfsg-3ubuntu0.1
Ubuntu 10.04 LTS
awstats - 6.9~dfsg-1ubuntu3.10.04.1
Ubuntu 9.10
awstats - 6.9~dfsg-1ubuntu3.9.10.1
Ubuntu 8.04 LTS
awstats - 6.7.dfsg-1ubuntu0.2
Ubuntu 6.06 LTS
awstats - 6.5-1ubuntu1.4

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References