USN-1058-1: PostgreSQL vulnerability

3 February 2011

postgresql-8.1, postgresql-8.3, postgresql-8.4 vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 10.10
  • Ubuntu 10.04 LTS
  • Ubuntu 9.10
  • Ubuntu 8.04 LTS
  • Ubuntu 6.06 LTS

Summary

Software Description

  • postgresql-8.4
  • postgresql-8.3
  • postgresql-8.1

Details

Geoff Keating reported that a buffer overflow exists in the intarray module’s input function for the query_int type. This could allow an attacker to cause a denial of service or possibly execute arbitrary code as the postgres user.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 10.10
postgresql-contrib-8.4 - 8.4.7-0ubuntu0.10.10
Ubuntu 10.04 LTS
postgresql-contrib-8.4 - 8.4.7-0ubuntu0.10.04
Ubuntu 9.10
postgresql-contrib-8.4 - 8.4.7-0ubuntu0.9.10
Ubuntu 8.04 LTS
postgresql-contrib-8.3 - 8.3.14-0ubuntu8.04
Ubuntu 6.06 LTS
postgresql-contrib-8.1 - 8.1.23-0ubuntu0.6.06.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References