USN-1091-1: Firefox and Xulrunner vulnerabilities

25 March 2011

firefox, firefox-{3.0,3.5}, xulrunner-1.9.2 vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 10.10
  • Ubuntu 10.04 LTS
  • Ubuntu 9.10
  • Ubuntu 8.04 LTS

Summary

Firefox/xulrunner update for blacklisted certificates

Software Description

  • firefox - safe and easy web browser from Mozilla
  • xulrunner-1.9.2 - XUL + XPCOM application runner
  • firefox-3.5 - dummy upgrade package for firefox-3.5 -> firefox
  • firefox-3.0 - dummy upgrade package for firefox-3.0 -> firefox

Details

It was discovered that several invalid HTTPS certificates were issued and revoked. An attacker could use these to perform a man-in-the-middle attack. These were placed on the certificate blacklist to prevent their misuse.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 10.10
firefox - 3.6.16+build1+nobinonly-0ubuntu0.10.10.1
xulrunner-1.9.2 - 1.9.2.16+build1+nobinonly-0ubuntu0.10.10.1
Ubuntu 10.04 LTS
firefox - 3.6.16+build1+nobinonly-0ubuntu0.10.04.1
xulrunner-1.9.2 - 1.9.2.16+build1+nobinonly-0ubuntu0.10.04.1
Ubuntu 9.10
firefox - 3.6.16+build1+nobinonly-0ubuntu0.9.10.1
xulrunner-1.9.2 - 1.9.2.16+build1+nobinonly-0ubuntu0.9.10.1
Ubuntu 8.04 LTS
firefox - 3.6.16+build1+nobinonly-0ubuntu0.8.04.1
xulrunner-1.9.2 - 1.9.2.16+build1+nobinonly-0ubuntu0.8.04.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system update you need to restart Firefox and any applications which use Xulrunner to make all the necessary changes.

References