USN-1103-1: tex-common vulnerability

4 April 2011

tex-common vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 10.10
  • Ubuntu 10.04 LTS

Summary

tex-common could be made to run programs as your login if it opened a specially crafted file.

Software Description

  • tex-common - common infrastructure for building and installing TeX

Details

Mathias Svensson discovered that the tex-common package contains an insecure shell_escape_commands configuration item. If a user or automated system were tricked into opening a specially crafted TeX file, a remote attacker could execute arbitrary code with user privileges.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 10.10
tex-common - 2.08ubuntu0.1
Ubuntu 10.04 LTS
tex-common - 2.06ubuntu0.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References