USN-1191-1: libXfont vulnerability

15 August 2011

libxfont vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 11.04
  • Ubuntu 10.10
  • Ubuntu 10.04 LTS

Summary

libXfont could be made to run programs as an administrator if it opened a specially crafted file.

Software Description

  • libxfont - X11 font rasterisation library

Details

Tomas Hoger discovered that libXfont incorrectly handled certain malformed compressed fonts. An attacker could use a specially crafted font file to cause libXfont to crash, or possibly execute arbitrary code in order to gain privileges.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 11.04
libxfont1 - 1:1.4.3-2ubuntu0.1
Ubuntu 10.10
libxfont1 - 1:1.4.2-1ubuntu0.1
Ubuntu 10.04 LTS
libxfont1 - 1:1.4.1-1ubuntu0.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system update you need to reboot your computer to make all the necessary changes.

References