USN-1247-1: Nova vulnerability

25 October 2011

nova vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 11.10

Summary

Nova could be made to expose sensitive information.

Software Description

  • nova - OpenStack Compute cloud infrastructure

Details

An information leak was discovered in Nova. An attacker with access to a valid EC2_ACCESS_KEY could obtain the corresponding EC2_SECRET_KEY for that user.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 11.10
python-nova - 2011.3-0ubuntu6.2

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References