USN-128-1: nasm vulnerability

18 May 2005

nasm vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 5.04
  • Ubuntu 4.10

Software Description

Details

Josh Bressers discovered a buffer overflow in the ieee_putascii() function of nasm. If an attacker tricked a user into assembling a malicious source file, they could exploit this to execute arbitrary code with the privileges of the user that runs nasm.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 5.04
nasm
Ubuntu 4.10
nasm

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

References