USN-1289-1: colord vulnerability

7 December 2011

colord vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 11.10

Summary

colord could be made to modify databases.

Software Description

  • colord - Service to manage device colour profiles

Details

It was discovered that colord incorrectly handled certain SQL queries. A local attacker could exploit this to modify arbitrary sqlite databases. On Ubuntu, colord runs as its own user by default, so standard file permissions would limit which databases could be altered.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 11.10
colord - 0.1.12-1ubuntu2.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system update you need to reboot your computer to make all the necessary changes.

References