USN-1305-1: Nova vulnerability

13 December 2011

nova vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 11.10

Summary

Nova could be made to overwrite files.

Software Description

  • nova - OpenStack Compute cloud infrastructure

Details

David Black discovered that Nova did not properly perform input validation during image registration. An attacker could exploit this by registering a crafted image using the EC2 API or S3/RegisterImage method and overwrite files as the nova user.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 11.10
python-nova - 2011.3-0ubuntu6.3

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References