USN-132-1: ImageMagick vulnerabilities

23 May 2005

imagemagick vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 5.04
  • Ubuntu 4.10

Software Description

Details

Damian Put discovered a buffer overflow in the PNM image decoder. Processing a specially crafted PNM file with a small “colors” value resulted in a crash of the application that used the ImageMagick library. (CAN-2005-1275)

Another Denial of Service vulnerability was found in the XWD decoder. Specially crafted invalid color masks resulted in an infinite loop which caused the application using the ImageMagick library to stop working and use all available CPU resources. (http://bugs.gentoo.org/show_bug.cgi?id=90423)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 5.04
libmagick6
Ubuntu 4.10
libmagick6

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

References