USN-136-1: binutils vulnerability

27 May 2005

binutils vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 5.04
  • Ubuntu 4.10

Software Description

Details

Tavis Ormandy found an integer overflow in the Binary File Descriptor (BFD) parser in the GNU debugger. The same vulnerable code is also present in binutils. By tricking an user into processing a specially crafted executable with the binutils tools (strings, objdump, nm, readelf, etc.), an attacker could exploit this to execute arbitrary code with the privileges of the user running the affected program.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 5.04
binutils
binutils-multiarch
Ubuntu 4.10
binutils
binutils-multiarch

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

References