USN-1365-1: Puppet vulnerability

14 February 2012

Puppet vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 11.10
  • Ubuntu 11.04
  • Ubuntu 10.10

Summary

Puppet would allow unintended access to resources over the network.

Software Description

  • puppet - Centralized configuration management

Details

It was discovered that Puppet would allow remote ralsh under certain circumstances. An attacker on an authenticated puppet node could exploit this to view or manipulate resources on other Puppet nodes.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 11.10
puppet-common - 2.7.1-1ubuntu3.4
Ubuntu 11.04
puppet-common - 2.6.4-2ubuntu2.7
Ubuntu 10.10
puppet-common - 2.6.1-0ubuntu2.5

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References