USN-1375-1: httplib2 vulnerability

27 February 2012

python-httplib2 vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 11.10
  • Ubuntu 11.04
  • Ubuntu 10.10
  • Ubuntu 10.04 LTS

Summary

httplib2 could be made to expose sensitive information over the network.

Software Description

  • python-httplib2 - comprehensive HTTP client library written for Python

Details

The httplib2 Python library earlier than version 0.7.0 did not perform any server certificate validation when using HTTPS connections. If a remote attacker were able to perform a man-in-the-middle attack, this flaw could be exploited to alter or compromise confidential information in applications that used the httplib2 library.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 11.10
python-httplib2 - 0.7.2-1ubuntu2~0.11.10.1
python3-httplib2 - 0.7.2-1ubuntu2~0.11.10.1
Ubuntu 11.04
python-httplib2 - 0.7.2-1ubuntu2~0.11.04.1
python3-httplib2 - 0.7.2-1ubuntu2~0.11.04.1
Ubuntu 10.10
python-httplib2 - 0.7.2-1ubuntu2~0.10.10.1
python3-httplib2 - 0.7.2-1ubuntu2~0.10.10.1
Ubuntu 10.04 LTS
python-httplib2 - 0.7.2-1ubuntu2~0.10.04.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

This update uses a new upstream release, which includes additional bug fixes.

References