USN-1454-1: Linux kernel vulnerability

25 May 2012

linux vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 8.04 LTS

Summary

The system could be made to crash or become unresponsive under certain conditions.

Software Description

  • linux - Linux kernel

Details

A flaw was found in the Linux’s kernels ext4 file system when mounted with a journal. A local, unprivileged user could exploit this flaw to cause a denial of service.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 8.04 LTS
linux-image-2.6.24-31-386 - 2.6.24-31.101
linux-image-2.6.24-31-generic - 2.6.24-31.101
linux-image-2.6.24-31-hppa32 - 2.6.24-31.101
linux-image-2.6.24-31-hppa64 - 2.6.24-31.101
linux-image-2.6.24-31-itanium - 2.6.24-31.101
linux-image-2.6.24-31-lpia - 2.6.24-31.101
linux-image-2.6.24-31-lpiacompat - 2.6.24-31.101
linux-image-2.6.24-31-mckinley - 2.6.24-31.101
linux-image-2.6.24-31-openvz - 2.6.24-31.101
linux-image-2.6.24-31-powerpc - 2.6.24-31.101
linux-image-2.6.24-31-powerpc-smp - 2.6.24-31.101
linux-image-2.6.24-31-powerpc64-smp - 2.6.24-31.101
linux-image-2.6.24-31-rt - 2.6.24-31.101
linux-image-2.6.24-31-server - 2.6.24-31.101
linux-image-2.6.24-31-sparc64 - 2.6.24-31.101
linux-image-2.6.24-31-sparc64-smp - 2.6.24-31.101
linux-image-2.6.24-31-virtual - 2.6.24-31.101
linux-image-2.6.24-31-xen - 2.6.24-31.101

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system update you need to reboot your computer to make all the necessary changes.

References