USN-1561-1: ubiquity-slideshow-ubuntu vulnerability

10 September 2012

ubiquity-slideshow-ubuntu vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 12.04 LTS

Summary

ubiquity-slideshow-ubuntu would allow unintended access to files over the network during system installation.

Software Description

  • ubiquity-slideshow-ubuntu - Ubiquity slideshow for Ubuntu

Details

Paul Mutton discovered that ubiquity-slideshow-ubuntu incorrectly handled the Twitter feed displayed during system installation. A remote attacker could use this flaw to inject code into the Twitter feed and read arbitrary files off the filesystem during system installation. This flaw has been resolved in the Ubuntu 12.04.1 LTS installation images by disabling the Twitter feed.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 12.04 LTS
ubiquity-slideshow-ubuntu - 58.2

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

Use of the Ubuntu 12.04.1 LTS installation images is required to resolve this issue.

References