USN-1665-1: unity-firefox-extension vulnerability

13 December 2012

unity-firefox-extension vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 12.10

Summary

unity-firefox-extension could be made to expose sensitive information over the network.

Software Description

  • unity-firefox-extension - Firefox extension: Unity Integration

Details

It was discovered that unity-firefox-extension bypassed the same origin policy checks in certain circumstances. If a user were tricked into opening a malicious page, an attacker could exploit this to steal confidential data or perform other security-sensitive operations.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 12.10
xul-ext-unity - 2.4.1-0ubuntu1.2

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system update you need to restart Firefox to make all the necessary changes.

References