USN-180-2: MySQL 4.1 vulnerability

5 December 2005

mysql-dfsg-4.1 vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 5.10

Software Description

Details

USN-180-1 fixed a vulnerability in the mysql-server package (which ships version 4.0). Version 4.1 is vulnerable against the same flaw.

Please note that this package is not officially supported in Ubuntu 5.10.

Origial advisory:

“AppSecInc Team SHATTER discovered a buffer overflow in the “CREATE FUNCTION” statement. By specifying a specially crafted long function name, a local or remote attacker with function creation privileges could crash the server or execute arbitrary code with server privileges.

However, the right to create function is usually not granted to untrusted users.”

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 5.10
mysql-server-4.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

References