USN-1956-1: HPLIP vulnerability

18 September 2013

hplip vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 13.04
  • Ubuntu 12.10
  • Ubuntu 12.04 LTS
  • Ubuntu 10.04 LTS

Summary

HPLIP could be tricked into bypassing polkit authorizations.

Software Description

  • hplip - HP Linux Printing and Imaging System (HPLIP)

Details

It was discovered that HPLIP was using polkit in an unsafe manner. A local attacker could possibly use this issue to bypass intended polkit authorizations.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 13.04
hplip - 3.13.3-1ubuntu0.1
Ubuntu 12.10
hplip - 3.12.6-3ubuntu4.1
Ubuntu 12.04 LTS
hplip - 3.12.2-1ubuntu3.2
Ubuntu 10.04 LTS
hplip - 3.10.2-2ubuntu2.3

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system update you need to reboot your computer to make all the necessary changes.

References