USN-2013-1: MAAS vulnerabilities

7 November 2013

maas vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 13.04
  • Ubuntu 12.10
  • Ubuntu 12.04 LTS

Summary

MAAS could be made to run programs as an administrator.

Software Description

  • maas - Ubuntu MAAS Server

Details

It was discovered that maas-import-pxe-files incorrectly loaded configuration information from the current working directory. A local attacker could execute code as an administrator if maas-import-pxe-files were run from an attacker-controlled directory. (CVE-2013-1057)

It was discovered that maas-import-pxe-files doesn’t cryptographically verify downloaded content. An attacker could modify images without detection. (CVE-2013-1058)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 13.04
maas-cluster-controller - 1.3+bzr1461+dfsg-0ubuntu2.3
Ubuntu 12.10
maas-cluster-controller - 1.2+bzr1373+dfsg-0ubuntu1.1
Ubuntu 12.04 LTS
maas-cluster-controller - 1.2+bzr1373+dfsg-0ubuntu1~12.04.4

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References