USN-212-1: libgda2 vulnerability

28 October 2005

libgda2 vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 5.10
  • Ubuntu 5.04
  • Ubuntu 4.10

Software Description

Details

Steve Kemp discovered two format string vulnerabilities in the logging handler of the Gnome database access library. Depending on the application that uses the library, this could have been exploited to execute arbitrary code with the permission of the user running the application.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 5.10
libgda2-1
libgda2-3
Ubuntu 5.04
libgda2-1
libgda2-3
Ubuntu 4.10
libgda2-1
libgda2-3

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

References