USN-2172-1: CUPS vulnerability

24 April 2014

cups vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 13.10
  • Ubuntu 12.10
  • Ubuntu 12.04 LTS
  • Ubuntu 10.04 LTS

Summary

CUPS could be made to expose sensitive information over the network.

Software Description

  • cups - Common UNIX Printing System™

Details

Alex Korobkin discovered that the CUPS web interface incorrectly protected against cross-site scripting (XSS) attacks. If an authenticated user were tricked into visiting a malicious website while logged into CUPS, a remote attacker could modify the CUPS configuration and possibly steal confidential data.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 13.10
cups - 1.7.0~rc1-0ubuntu5.3
Ubuntu 12.10
cups - 1.6.1-0ubuntu11.6
Ubuntu 12.04 LTS
cups - 1.5.3-0ubuntu8.2
Ubuntu 10.04 LTS
cups - 1.4.3-1ubuntu1.11

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References