USN-2213-1: Dovecot vulnerability

15 May 2014

dovecot vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 14.04 LTS
  • Ubuntu 13.10
  • Ubuntu 12.10
  • Ubuntu 12.04 LTS
  • Ubuntu 10.04 LTS

Summary

Dovecot could be made to stop responding if it received specially crafted network traffic.

Software Description

  • dovecot - IMAP and POP3 email server

Details

It was discovered that Dovecot incorrectly handled closing inactive SSL/TLS connections. A remote attacker could use this issue to cause Dovecot to stop responding to new connections, resulting in a denial of service.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 14.04 LTS
dovecot-core - 1:2.2.9-1ubuntu2.1
dovecot-imapd - 1:2.2.9-1ubuntu2.1
dovecot-pop3d - 1:2.2.9-1ubuntu2.1
Ubuntu 13.10
dovecot-core - 1:2.1.7-7ubuntu3.1
dovecot-imapd - 1:2.1.7-7ubuntu3.1
dovecot-pop3d - 1:2.1.7-7ubuntu3.1
Ubuntu 12.10
dovecot-core - 1:2.1.7-1ubuntu2.1
dovecot-imapd - 1:2.1.7-1ubuntu2.1
dovecot-pop3d - 1:2.1.7-1ubuntu2.1
Ubuntu 12.04 LTS
dovecot-core - 1:2.0.19-0ubuntu2.1
dovecot-imapd - 1:2.0.19-0ubuntu2.1
dovecot-pop3d - 1:2.0.19-0ubuntu2.1
Ubuntu 10.04 LTS
dovecot-imapd - 1:1.2.9-1ubuntu6.6
dovecot-pop3d - 1:1.2.9-1ubuntu6.6

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References