USN-234-1: cpio vulnerability

3 January 2006

cpio vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 5.10
  • Ubuntu 5.04
  • Ubuntu 4.10

Software Description

Details

Richard Harms discovered that cpio did not sufficiently validate file properties when creating archives. Files with e. g. a very large size caused a buffer overflow. By tricking a user or an automatic backup system into putting a specially crafted file into a cpio archive, a local attacker could probably exploit this to execute arbitrary code with the privileges of the target user (which is likely root in an automatic backup system).

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 5.10
cpio
Ubuntu 5.04
cpio
Ubuntu 4.10
cpio

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

References