USN-2362-1: Bash vulnerability

24 September 2014

bash vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 14.04 LTS
  • Ubuntu 12.04 LTS
  • Ubuntu 10.04 LTS


Bash allowed bypassing environment restrictions in certain environments.

Software Description

  • bash - GNU Bourne Again SHell


Stephane Chazelas discovered that Bash incorrectly handled trailing code in function definitions. An attacker could use this issue to bypass environment restrictions, such as SSH forced command environments.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 14.04 LTS
bash - 4.3-7ubuntu1.1
Ubuntu 12.04 LTS
bash - 4.2-2ubuntu2.2
Ubuntu 10.04 LTS
bash - 4.1-2ubuntu3.1

To update your system, please follow these instructions:

In general, a standard system update will make all the necessary changes.