USN-2382-1: Requests vulnerabilities

14 October 2014

requests vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 14.04 LTS

Summary

Requests could be made to expose authentication credentials over the network.

Software Description

  • requests - elegant and simple HTTP library for Python

Details

Jakub Wilk discovered that Requests incorrectly reused authentication credentials after being redirected. An attacker could possibly use this issue to obtain authentication credentials intended for another site. (CVE-2014-1829, CVE-2014-1830)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 14.04 LTS
python-requests - 2.2.1-1ubuntu0.1
python3-requests - 2.2.1-1ubuntu0.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References