USN-239-1: libapache2-mod-auth-pgsql vulnerability

9 January 2006

libapache2-mod-auth-pgsql vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 5.10
  • Ubuntu 5.04
  • Ubuntu 4.10

Software Description

Details

Several format string vulnerabilities were discovered in the error logging handling. By sending specially crafted user names, an unauthenticated remote attacker could exploit this to crash the Apache server or possibly even execute arbitrary code with the privileges of Apache (user ‘www-data’).

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 5.10
libapache2-mod-auth-pgsql
Ubuntu 5.04
libapache2-mod-auth-pgsql
Ubuntu 4.10
libapache2-mod-auth-pgsql

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

References