USN-24-1: openssl script vulnerability

12 November 2004

openssl script vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 4.10

Software Description

Details

Recently, Trustix Secure Linux discovered a vulnerability in the openssl package. The auxiliary script “der_chop” created temporary files in an insecure way, which could allow a symlink attack to create or overwrite arbitrary files with the privileges of the user invoking the program.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 4.10
openssl

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

References