USN-2440-1: Mutt vulnerability

11 December 2014

mutt vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 14.10
  • Ubuntu 14.04 LTS
  • Ubuntu 12.04 LTS
  • Ubuntu 10.04 LTS

Summary

The mutt mail client could be made to crash if it opened a specially crafted email.

Software Description

  • mutt - text-based mailreader supporting MIME, GPG, PGP and threading

Details

Jakub Wilk discovered that the write_one_header function in mutt did not properly handle newline characters at the beginning of a header. An attacker could specially craft an email to cause mutt to crash, resulting in a denial of service.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 14.10
mutt - 1.5.23-1.1ubuntu0.2
mutt-patched - 1.5.23-1.1ubuntu0.2
Ubuntu 14.04 LTS
mutt - 1.5.21-6.4ubuntu2.1
mutt-patched - 1.5.21-6.4ubuntu2.1
Ubuntu 12.04 LTS
mutt - 1.5.21-5ubuntu2.2
mutt-patched - 1.5.21-5ubuntu2.2
Ubuntu 10.04 LTS
mutt - 1.5.20-7ubuntu1.3
mutt-patched - 1.5.20-7ubuntu1.3

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system update you need to restart any running instances of mutt to make all the necessary changes.

References