USN-249-1: xpdf/poppler/kpdf vulnerabilities

15 February 2006

xpdf, poppler, kdegraphics vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 5.10
  • Ubuntu 5.04
  • Ubuntu 4.10

Software Description

Details

The splash image handler in xpdf did not check the validity of coordinates. By tricking a user into opening a specially crafted PDF file, an attacker could exploit this to trigger a buffer overflow which could lead to arbitrary code execution with the privileges of the user.

The poppler library and kpdf also contain xpdf code, and thus are affected by the same vulnerability.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 5.10
kpdf
libpoppler0c2
xpdf-reader
xpdf-utils
Ubuntu 5.04
kpdf
libpoppler0c2
xpdf-reader
xpdf-utils
Ubuntu 4.10
kpdf
libpoppler0c2
xpdf-reader
xpdf-utils

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

References