USN-2507-1: e2fsprogs vulnerabilities

23 February 2015

e2fsprogs vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 14.10
  • Ubuntu 14.04 LTS
  • Ubuntu 12.04 LTS
  • Ubuntu 10.04 LTS

Summary

e2fsprogs could be made to crash or run programs as an administrator if it processed a specially crafted filesystem image.

Software Description

  • e2fsprogs - ext2/ext3/ext4 file system utilities

Details

Jose Duart discovered that e2fsprogs incorrectly handled invalid block group descriptor data. A local attacker could use this issue with a crafted filesystem image to possibly execute arbitrary code. (CVE-2015-0247, CVE-2015-1572)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 14.10
e2fsprogs - 1.42.10-1.1ubuntu1.2
Ubuntu 14.04 LTS
e2fsprogs - 1.42.9-3ubuntu1.2
Ubuntu 12.04 LTS
e2fsprogs - 1.42-1ubuntu2.2
Ubuntu 10.04 LTS
e2fsprogs - 1.41.11-1ubuntu2.3

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References