USN-251-1: libtasn vulnerability

17 February 2006

libtasn1-2 vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 5.10
  • Ubuntu 5.04
  • Ubuntu 4.10

Software Description

Details

Evgeny Legerov discovered a buffer overflow in the DER format decoding function of the libtasn library. This library is mainly used by the GNU TLS library; by sending a specially crafted X.509 certificate to a server which uses TLS encryption/authentication, a remote attacker could exploit this to crash that server process and possibly even execute arbitrary code with the privileges of that server.

In order to fix the vulnerability in libtasn, several internal function signatures had to be changed; some of these functions are used by the GNU TLS library, so that library needs to be updated as well.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 5.10
libgnutls10
libgnutls11
libtasn1-2
Ubuntu 5.04
libgnutls10
libgnutls11
libtasn1-2
Ubuntu 4.10
libgnutls10
libgnutls11
libtasn1-2

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

References