USN-252-1: gnupg vulnerability

18 February 2006

gnupg vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 5.10
  • Ubuntu 5.04
  • Ubuntu 4.10

Software Description

Details

Tavis Ormandy discovered a potential weakness in the signature verification of gnupg. gpgv and gpg –verify returned a successful exit code even if the checked file did not have any signature at all. The recommended way of checking the result is to evaluate the status messages, but some third party applications might just check the exit code for determining whether or not a signature is valid. These applications could be tricked into erroneously reporting a valid signature.

Please note that this does not affect the Ubuntu package signature checks.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 5.10
gnupg
Ubuntu 5.04
gnupg
Ubuntu 4.10
gnupg

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

References