USN-2578-1: LibreOffice vulnerabilities

27 April 2015

libreoffice vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 14.10
  • Ubuntu 14.04 LTS
  • Ubuntu 12.04 LTS

Summary

LibreOffice could be made to crash or run programs as your login if it opened a specially crafted file.

Software Description

  • libreoffice - Office productivity suite

Details

Alexander Cherepanov discovered that LibreOffice incorrectly handled certain RTF files. If a user were tricked into opening a specially crafted RTF document, a remote attacker could cause LibreOffice to crash, and possibly execute arbitrary code. (CVE-2014-9093)

It was discovered that LibreOffice incorrectly handled certain HWP files. If a user were tricked into opening a specially crafted HWP document, a remote attacker could cause LibreOffice to crash, and possibly execute arbitrary code. (CVE-2015-1774)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 14.10
libreoffice-core - 1:4.3.7~rc2-0ubuntu1
Ubuntu 14.04 LTS
libreoffice-core - 1:4.2.8-0ubuntu2
Ubuntu 12.04 LTS
libreoffice-core - 1:3.5.7-0ubuntu8

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system update you need to restart LibreOffice to make all the necessary changes.

References