USN-258-1: PostgreSQL vulnerability

27 February 2006

postgresql-7.4, postgresql-8.0, postgresql vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 5.10
  • Ubuntu 5.04
  • Ubuntu 4.10

Software Description

Details

Akio Ishida discovered that the SET SESSION AUTHORIZATION command did not properly verify the validity of its argument. An authenticated PostgreSQL user could exploit this to crash the server.

However, this does not affect the official binary Ubuntu packages. The crash can only be triggered if the source package is rebuilt with assertions enabled (which is not the case in the official binary packages).

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 5.10
postgresql
postgresql-7.4
postgresql-8.0
Ubuntu 5.04
postgresql
postgresql-7.4
postgresql-8.0
Ubuntu 4.10
postgresql
postgresql-7.4
postgresql-8.0

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

References