USN-2628-1: strongSwan vulnerability

8 June 2015

strongswan vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 15.04
  • Ubuntu 14.10
  • Ubuntu 14.04 LTS

Summary

strongSwan could be made to expose sensitive information over the network.

Software Description

  • strongswan - IPsec VPN solution

Details

Alexander E. Patrakov discovered that strongSwan incorrectly handled certain IKEv2 setups. A malicious server could possibly use this issue to obtain user credentials.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 15.04
strongswan-ike - 5.1.2-0ubuntu5.2
Ubuntu 14.10
strongswan-ike - 5.1.2-0ubuntu3.3
Ubuntu 14.04 LTS
strongswan-ike - 5.1.2-0ubuntu2.3

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References