USN-2659-1: cups-filters vulnerabilities

6 July 2015

cups-filters vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 15.04
  • Ubuntu 14.10
  • Ubuntu 14.04 LTS
  • Ubuntu 12.04 LTS

Summary

cups-filters could be made to crash or run programs as the lp user if it processed a specially crafted print job.

Software Description

  • cups-filters - OpenPrinting CUPS Filters

Details

Petr Sklenar discovered that the cups-filters texttopdf filter incorrectly handled line sizes. A remote attacker could use this issue to cause a denial of service, or possibly execute arbitrary code as the lp user. (CVE-2015-3258, CVE-2015-3279)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 15.04
cups-filters - 1.0.67-0ubuntu2.2
Ubuntu 14.10
cups-filters - 1.0.61-0ubuntu2.3
Ubuntu 14.04 LTS
cups-filters - 1.0.52-0ubuntu1.5
Ubuntu 12.04 LTS
cups-filters - 1.0.18-0ubuntu0.4

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References