USN-2676-1: NBD vulnerabilities

22 July 2015

nbd vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 15.04
  • Ubuntu 14.10
  • Ubuntu 14.04 LTS
  • Ubuntu 12.04 LTS

Summary

Several security issues were fixed in NBD.

Software Description

  • nbd - Network Block Device protocol

Details

It was discovered that NBD incorrectly handled IP address matching. A remote attacker could use this issue with an IP address that has a partial match and bypass access restrictions. This issue only affected Ubuntu 12.04 LTS. (CVE-2013-6410)

Tuomas Räsänen discovered that NBD incorrectly handled wrong export names and closed connections during negotiation. A remote attacker could use this issue to cause NBD to crash, resulting in a denial of service. This issue only affected Ubuntu 12.04 LTS. (CVE-2013-7441)

Tuomas Räsänen discovered that NBD incorrectly handled signals. A remote attacker could use this issue to cause NBD to crash, resulting in a denial of service. (CVE-2015-0847)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 15.04
nbd-server - 1:3.8-4ubuntu0.1
Ubuntu 14.10
nbd-server - 1:3.8-1ubuntu0.1
Ubuntu 14.04 LTS
nbd-server - 1:3.7-1ubuntu0.1
Ubuntu 12.04 LTS
nbd-server - 1:2.9.25-2ubuntu1.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References