USN-268-1: Kaffeine vulnerability

7 April 2006

kaffeine vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 5.10
  • Ubuntu 5.04

Software Description

Details

Marcus Meissner discovered a buffer overflow in the http_peek() function. By tricking an user into opening a specially crafted playlist URL with Kaffeine, a remote attacker could exploit this to execute arbitrary code with the user’s privileges.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 5.10
kaffeine
Ubuntu 5.04
kaffeine

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

References