USN-2711-1: Net-SNMP vulnerabilities

17 August 2015

net-snmp vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 15.04
  • Ubuntu 14.04 LTS
  • Ubuntu 12.04 LTS

Summary

Net-SNMP could be made to crash or run programs if it received specially crafted network traffic.

Software Description

  • net-snmp - SNMP (Simple Network Management Protocol) server and applications

Details

It was discovered that Net-SNMP incorrectly handled certain trap messages when the -OQ option was used. A remote attacker could use this issue to cause Net-SNMP to crash, resulting in a denial of service. (CVE-2014-3565)

Qinghao Tang discovered that Net-SNMP incorrectly handled SNMP PDU parsing failures. A remote attacker could use this issue to cause Net-SNMP to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2015-5621)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 15.04
libsnmp30 - 5.7.2~dfsg-8.1ubuntu5.1
Ubuntu 14.04 LTS
libsnmp30 - 5.7.2~dfsg-8.1ubuntu3.1
Ubuntu 12.04 LTS
libsnmp15 - 5.4.3~dfsg-2.4ubuntu1.3

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References