USN-272-1: cyrus-sasl2 vulnerability

24 April 2006

cyrus-sasl2 vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 5.10
  • Ubuntu 5.04
  • Ubuntu 4.10

Software Description

Details

A Denial of Service vulnerability has been discovered in the SASL authentication library when using the DIGEST-MD5 plugin. By sending a specially crafted realm name, a malicious SASL server could exploit this to crash the application that uses SASL.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 5.10
libsasl2-modules-gssapi-heimdal
Ubuntu 5.04
libsasl2-modules-gssapi-heimdal
Ubuntu 4.10
libsasl2-modules-gssapi-heimdal

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

References