USN-273-1: Ruby vulnerability

24 April 2006

ruby1.8 vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 5.10
  • Ubuntu 5.04
  • Ubuntu 4.10

Software Description

Details

Yukihiro Matsumoto reported that Ruby’s HTTP module uses blocking sockets. By sending large amounts of data to a server application that uses this module, a remote attacker could exploit this to render this application unusable and not respond any more to other clients (Denial of Service).

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 5.10
libruby1.8
libwebrick-ruby1.8
Ubuntu 5.04
libruby1.8
libwebrick-ruby1.8
Ubuntu 4.10
libruby1.8
libwebrick-ruby1.8

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

References